Tag Archives: r4isdhc 3ds v4.5

Is it really that almost all flashcart can support 3DS V4.5.0-10 and DSi V1.45 ?

Just as we knew,most of flashcart have been blocked since Nintendo released the firmware update for 3DS/XL and DSi.Yet,today,according to a confirmed news that more and more 3ds flashcart have bypassed the block and let’s read following content to get … Continue reading

Posted in 3DS flashcard, DS News | Tagged , , , , , , , | Leave a comment